Error with gulp build

ForumCategory: InstallationError with gulp build
PodpeaPaul asked 5 months ago

Hi,
I am having an issue when trying to build the theme.
when I run gulp build I get the following output. I have been able to build the project without an issue but today I ran into the error.
Could you advise?
 
 
(node:9992) DeprecationWarning: process.EventEmitter is deprecated. Use require(‘events’) instead.
[16:04:46] Starting ‘clean’…
[16:04:46] Finished ‘clean’ after 36 ms
[16:04:46] Starting ‘build’…
[16:04:46] Starting ‘jshint’…
[16:04:46] Starting ‘styles’…
[16:04:47] Starting ‘images’…
[16:04:47] Starting ‘lang’…
[16:04:47] Starting ‘fonts’…
[16:04:47] Starting ‘extras’…
[16:04:47] Finished ‘build’ after 1.42 s
[16:04:49] Finished ‘extras’ after 1.51 s
[16:04:49] Finished ‘lang’ after 1.83 s
[16:04:51] Finished ‘images’ after 3.52 s
[16:04:53] Finished ‘styles’ after 6.61 s
[16:04:53] Starting ‘html’…
events.js:160
throw er; // Unhandled ‘error’ event
^
Error: styles\main.css: error: couldn’t process source due to parse error
Unexpected character ‘@’ (2:0)
at transform (C:\xampp\htdocs\kwd-crm\node_modules\gulp-ng-annotate\index.js:20:11)
at Transform._transform (C:\xampp\htdocs\kwd-crm\node_modules\gulp-ng-annotate\index.js:68:25)
at Transform._read (C:\xampp\htdocs\kwd-crm\node_modules\through2\node_modules\readable-stream\lib\_stream_transform.js:184:10)
at Transform._write (C:\xampp\htdocs\kwd-crm\node_modules\through2\node_modules\readable-stream\lib\_stream_transform.js:172:12)
at doWrite (C:\xampp\htdocs\kwd-crm\node_modules\through2\node_modules\readable-stream\lib\_stream_writable.js:237:10)
at writeOrBuffer (C:\xampp\htdocs\kwd-crm\node_modules\through2\node_modules\readable-stream\lib\_stream_writable.js:227:5)
at Transform.Writable.write (C:\xampp\htdocs\kwd-crm\node_modules\through2\node_modules\readable-stream\lib\_stream_writable.js:194:11)
at Readable.ondata (_stream_readable.js:555:20)
at emitOne (events.js:96:13)
at Readable.emit (events.js:188:7)

admin Staff replied 5 months ago

You need to download Node LTS. You can refer https://nodejs.org/en/.

1 Answers
PodpeaPaul answered 5 months ago

I solved this by downgrading from node 6.7.0 to 5.0.0